The version of Moodle that you are about to install or upgrade to contains unstable "Release candidate" development code that is not suitable for use on most production sites. If this is not what you wanted then you should make sure you are updating from a STABLE branch of the Moodle code. See Moodle Docs for more details.